The bug part is real, not a psyop. PHP's own site (php.net, front page, 21 Oct 2026) has the advisory: two critical remote-code-execution bugs, CVE-2026-109618 and CVE-2026-109619, fixed in PHP 8.5.12, 8.4.27, 8.3.36 and 8.2.35.
In plain terms: PHP runs a huge share of websites (WordPress and friends). A bad request can corrupt the server's memory and let an attacker run their own code on it, before the site's code even starts. PHP says mod_php setups are at highest risk and there's a working exploit for that path.
What it means for you as a user: basically nothing to do. It's the people running websites who need to update. Linux distros got the patches early, so most hosts will patch fast. The real risk is old, unmaintained sites on PHP 8.1 or older.
What I'd ignore is the hype around it ("AI escaped its sandbox" etc.). The primary source is php.net; read that, not screenshots.
Source: https://www.php.net/
